Smartlife: cosa succede quando faccio un reso ad Amazon di un oggetto connesso a wifi?

Oggi, con la collaborazione del mio vicino di casa Massimo (che ringrazio), abbiamo testato un dubbio che attanaglia sicuramente molti nerd in giro per il mondo: cosa succede quando faccio il reso di un oggetto wifi Smartlife (lampadine, prese intelligenti…) ad Amazon? Se lascio associato l’oggetto nel mio account Smartlife riuscirò a controllarlo quando esso tornerà online?

Ecco come è andato l’esperimento.

Massimo ha associato, alla sua wifi di casa e al suo account Smartlife, 2 lampadine smart della teckin (trovate il link sopra).

Fatto questo, me le ha date, senza rimuoverle dall’app.

Una volta ricevute, le ho dovuto ovviamente resettarle per connetterle alla mia wifi (accensione-spegnimento veloce per 3 volte fino a che la lampadina non lampeggia velocemente).

Connesse finalmente alla mia rete wifi e al mio account Smartlife, Massimo mi ha comunicato di averle perse dal suo account.

Speravo ci potesse essere qualche colpo di scena per far avere un picco di visitatori al mio povero blog, ma purtroppo per me, i cinesi questa volta hanno fatto le cose per bene 😀

Alla prossima!

Netgear A6210/AC1200 WiFi USB Adapter on Raspberry 4 – raspbian

Are you going crazy with your A6210 Netgear WiFi USB Adapter on Linux?
I guess you will find the solution here!

First of all, get and compile the driver module from here (follow the readme instructions):

https://github.com/kaduke/Netgear-A6210

It should work just out of the box after the installation of this driver, but, if you got a similar error:

[    4.523632] mt76x2u 2-1:1.0: Direct firmware load for mediatek/mt7662u_rom_patch.bin failed with error -2
[    5.278780] mt76x2u: probe of 2-1:1.0 failed with error -2
[    5.279262] usbcore: registered new interface driver mt76x2u

You will have to download the mt7662* driver from here:

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/mediatek

and then put the module in the right place:

# mkdir /lib/firmware/mediatek
# cp mt7662* /lib/firmware/mediatek/

Unplug and plug it again the adapter and now should works fine!

I’ve tested it with a Raspberry 4 with raspian buster

Linux raspberrypi 4.19.93-v7l+ #1290 SMP Fri Jan 10 16:45:11 GMT 2020 armv7l GNU/Linux

If you have any issue on Raspberry 3, please take a look here

https://github.com/jurobystricky/Netgear-A6210/issues/57

and edit file /boot/cmdline.txt and add coherent_pool=4M to the end of the file.

That’s it!